Problème Port USB sur MacOS

Bonjour,
J’essaie de faire les premiers programmes sur ma gamebuino, mais j’ai un problème avec les ports.
Le seul port reconnu par Arduino sur mon mac est celui-ci :
/dev/cu.Bluetooth-Incoming-Port
Je ne vois pas comment faire apparaître le port suivant : Arduino/Genuino Zero (Native USB Port)
Savez-vous comment le faire apparaître ?
Merci beaucoup

Salut @Alien94,

Connecte ta Gamebuino à ton Mac sur un port USB, puis allume-la.

Première méthode

Si la ligne de commande ne te fait pas peur, tu peux ouvrir un terminal et saisis la commande suivante :

ioreg -p IOUSB -l -w 0 | less

Le mode interactif de la commande less te permet alors d’examiner le résultat (qui peut être très verbeux).

Touches [UP] et [DOWN] pour faire défiler vers le haut / bas.
Touche [H] pour afficher l’aide (puis [Q] pour sortir).

Lance une recherche sur la chaîne Arduino en saisissant le motif suivant :

/Arduino

Tu devrais tomber sur un bloc qui ressemble à ça :

| +-o Arduino Zero@14320000  <class AppleUSBDevice, id 0x10008a9cd, registered, matched, active, busy 0 (0 ms), retain 14>
|     {
|       "sessionID" = 642805807688566
|       "idProduct" = 32845
|       "iManufacturer" = 1
|       "bDeviceClass" = 239
|       "bMaxPacketSize0" = 64
|       "bcdDevice" = 256
|       "iProduct" = 2
|       "iSerialNumber" = 3
|       "bNumConfigurations" = 1
|       "Bus Power Available" = 250
|       "USB Address" = 34
|       "Built-In" = No
|       "locationID" = 338821120
|       "bDeviceSubClass" = 2
|       "bcdUSB" = 512
|       "USB Product Name" = "Arduino Zero"
|       "PortNum" = 2
|       "non-removable" = "no"
|       "AppleUSBAlternateServiceRegistryID" = 4295535051
|       "bDeviceProtocol" = 1
|       "IOCFPlugInTypes" = {"9dc7b780-9ec0-11d4-a54f-000a27052861"="IOUSBHostFamily.kext/Contents/PlugIns/IOUSBLib.bundle"}
|       "IOPowerManagement" = {"DevicePowerState"=0,"CurrentPowerState"=3,"CapabilityFlags"=65536,"MaxPowerState"=4,"DriverPowerState"=3}
|       "kUSBCurrentConfiguration" = 1
|       "Device Speed" = 1
|       "USB Vendor Name" = "Arduino LLC"
|       "idVendor" = 9025
|       "IOGeneralInterest" = "IOCommand is not serializable"
|       "kUSBProductString" = "Arduino Zero"
|       "kUSBVendorString" = "Arduino LLC"
|       "IOClassNameOverride" = "IOUSBDevice"
|     }

Seconde méthode

Si tu préfères l’interface graphique :

Plan B

Si tu ne vois pas apparaître l’item Arduino Zero, c’est probablement parce-que ton câble USB ne fournit que l’alimentation. Dans ce cas, il faut en choisir un autre qui permette également l’échange de données.

As-tu conservé le câble (un peu court certes) fourni avec la console ?

En espérant que ça t’aidera à y voir plus clair…
Steph

1 Like

Bonjour @Alien94 .
Tout d’abord, bienvenue sur le forum Gamebuino !
La console est elle branchée sur le MAC avec le câble USB fournit, et allumée ?
Jean-Marie

Bonjour,
Les explications de Steph vous ont elle permit de solutionner ce problème ?

Bonjour,
Oui merci pour les explications, elles sont très claires. J’utilise bien le cable USB fournit par la gamebuino, mais à priori il ne fonctionne pas correctement, puisque la gamebuino n’est toujours pas vu sur le port USB.
Merci,

Tu peux essayer avec un autre câble USB (qui permet l’échange de données) ? Histoire qu’on élimine un éventuel problème de câble…

1 Like