META Emulator not working on newer binaries

Hello there !

So I basically decided to get back to coding on the Gamebuino after some months. I used to use the META Emulator for debugging and convenience in the general dev process, but the new binaries I create don’t load anymore on the emulator (nothing happen, no loading, not even a black screen) freezing the program.

I’m using all the latest version of Arduino SAMD (1.8.3) and META Gamebuino (1.2.2) boards, as well as the latest Gamebuino META (1.3.2) library version.
I’ve tried loading my old projects binaries and they all work fine. Is this common to the emulator ? I can’t make it without it…

Thanks for the help !

1 Like

Interesting, I wonder if something has changed with how the screen is driven or the DMA is done.

I’m not sure if this is related, but the binaries I build with gcc 8 don’t work on the emulator either.

I pinged aoneill on Discord, he wrote the emulator.

1 Like

I’ll take a look. Might be the weekend before I get a chance.

@Na_Waku or @Alban - eriban contributed a fix to the DMA on the emulator a few weeks ago, but I don’t know if that has made it to the emulator hosted on gamebuino.com yet. Shot in the dark, but could you see if the new binaries work at http://games.aoneill.com/meta-emulator/?

1 Like

I did put the very same link in my post. I’ve just tested it…and it doesn’t work :confused:

Ok, I believe I have fixed the problem. I was able to reproduce the problem with one of my games compiled with the latest library. I found a couple of instructions (REV and a certain MOV) were missing. I’ve updated http://games.aoneill.com/meta-emulator/.

Since I only tested this with a single game, there might be other problems. If someone could test this on their game, that would be great. If it isn’t working, open the browser developer console and see if there is a message that starts with “NO INSTRUCTIONHANDLER!” That may help me.

4 Likes

Ooo it works again like a charm for me. Great job ! :smiley:

2 Likes

I’ve tried my latest build of Project88, which just showed a blank screen: now, not only does it run, but the display is perfect! Thanks a lot!

1 Like

Hello @aoneill , I just released a game https://gamebuino.com/fr/creations/glitch, but it seems that it’s not working on the emulator… What could be the problem ? Nothing happens but a black screen… Did I forget to do something ?

But it work when I upload it here https://gamebuino.com/fr/creations/meta-emulator … I don’t understand…

It throws that error in the browser console : NO INSTRUCTIONHANDLER! 0x11b2e: 0x4601; prev addr: 0x11b2c

Yeah, the emulator linked to there is a slightly newer version. I’ll have to reach out to the Gamebuino people to see if they want to update the version embedded in the website.

1 Like

Aaah ok, of course the version on the website is still the old one… OK !