Arduino et les vieux Mac

Bonjour à tous ! J’ai reçu aujourd’hui ma gamebuino ! (trop content). Je vais pouvoir commencer en douceur à apprendre à coder . Ou pas.
En effet, mon mac (10.6.8) ne supporte que la version 1.0.6 de arduino. Et non pas la version 1.8
Je ne parviens donc pas à installer les paramètres comme très bien décris dans le tuto…

Quelqu’un a une idée ??

1 Like

Coucou, je n’ai plus cette version mais pour que l’on t’aide, il faudrait que tu nous donnes plus de détail sur la partie que tu n’arrives pas à réaliser: la différence qu’il y a par exemple entre ce qui est expliqué et ce que tu as à l’écran comme nous somme quasiment tous en version 1.8.
(Les possesseurs de MAC me corrigeront peut être s’ils sont resté en 1.6 mais je ne crois pas)

Lorsque je vais dans les préférences , je ne trouve pas d’emplacement pour “URL de gestionnaire de cartes supplémentaires”. Ensuite, dans “outil”, “type de carte”, je ne trouve pas le gestionnaire de cartes…
En attendant j’ai fait un peu de python ^^ . Mais j’ai cru comprendre qu’on ne pouvait pas utiliser le programme sans être connecté à l’ordinateur… :frowning_face:

  1. Démarrer l’IDE (minimum version 1.6.4)
  2. Ouvrir le menu « Fichier | Préférences «
  3. Au bas de la fenêtre, il y a une ligne « URL des gestionnaire de carte supplémentaire » (je n’ai pas fait de faute de frappe !), avec un champ vide et un bouton au bout. Cliquer sur ce bouton.
  4. Dans la nouvelle fenêtre, entrer chaque URL de JSON définition de boards sur une nouvelle ligne. Une liste de librairies que j’utilise fréquemment se trouve en fin d’article. Cliquer sur le bouton « Ok ».
  5. Ouvrir le menu « Outils | Type de carte | Gestionnaire de carte »
    Dans la liste qui s’affiche, il se trouvent toutes les nouvelles librairies de boards installées au point 4. Si ce n’est pas le cas, fermer et réouvrir cette même fenêtre permet de résoudre le problème, elle a parfois du mal à se mettre à jour.

J’ai eu le même problème. J’ai acheté un Mac plus récent…

Bon…Pour Arduino 1.6.4 il me faut au moins un OS X 10.7
C’est donc un échec.
Sa me laisse du temps pour apprendre à coder, d’ici que je trouve un ordi compatible dans mon budget…
Merci pour les infos en tout cas !

il y a certainement moyen d’ajouter le support de la carte et les libs de manière manuelle

aussi il existe des alternative à l’ide arduino,

déjà il existe la version ligne de commande : https://arduino.github.io/arduino-cli/

après tu as entre autre https://platformio.org/ la je le teste dans sa version plugin pour Atom, j’ai pu importer un projet et installer la lib officielle, la board manque dans celles officielles (+ de 800), j’ai mis “arduino zero générique” pour tester mais pour le moment la lib officielle me jette à la compilation à cause de la board :- D

il existe encore d’autres alternatives, faut farfouiller et tester :’)

Sur mon vieux Mac, j’arrivais à coder pour Arduboy. Mais certains jeux étaient trop lourds avec une ancienne version de Arduino. Du coup j’enlevais des gros sprites pour que ça puisse alléger et compiler.